Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

Webroar not able to deploy a specific app

#21

Hi,

My WebROaR is able to deploy standard Rails Applications but there is a specific application which has some plugins installed which its not able to deploy. The Rails App runs fine when run with WebRick or mongrel both in production and development environment.

The error log shows the following.

WebROaR-0.3.1: Log file opened at Tue May  4 09:47:25 2010
Tue May  4 09:47:25 2010-13321-Info:setting log level to SEVERE
WebROaR-0.3.1: Log file opened at Tue May  4 09:47:25 2010
Tue May  4 09:47:25 2010-13322-Info:setting log level to SEVERE
Tue May  4 09:47:25 2010-13321-Info:Ruby interpreter initialized successfully
Tue May  4 09:47:25 2010-13322-Info:Ruby interpreter initialized successfully
Tue May  4 09:47:27 2010-13321-Error:ArgumentError-couldn't find HOME environment -- expanding `~'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails_generator/lookup.rb:35:in `expand_path'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails_generator/lookup.rb:35:in `user_home'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails_generator/lookup.rb:114:in `use_component_sources!'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails_generator/lookup.rb:55:in `included'

I am attaching the full log trace.

Any help is appreciated.

Reported by GeekTantra · May 4th, 2010 @ 09:56 AM

State: resolved
Milestone: none
Assigned to: Dharmarth Shah Dharmarth Shah

Activity

  1. GeekTantra
    GeekTantra

    This doesn't happen when I create the app in a fresh install of WebROaR, But whenever I do a service webroar restart this bug appears.

    May 4th, 2010 @ 03:20 PM

  2. Dharmarth Shah
    Dharmarth Shah
    • Tag changed from internal server error to application loading, internal server error

    Thanks for taking time to report the issue.

    From the log, we felt it could be Hobo application creating this problem, but sample Hobo application is running perfectly fine at our end.

    Could you please give us following details to debug the issue throughly?

    1. Rails plugins name which are likely be creating the issue
    2. Operating System
    3. Ruby version

    May 4th, 2010 @ 05:34 PM

  3. Dharmarth Shah
    Dharmarth Shah
    • State changed from new to open

    May 4th, 2010 @ 07:18 PM

  4. GeekTantra
    GeekTantra

    Thanks for the reply.

    As I mentioned earlier the error doesn't appear when WebROaR is freshly installed. I am able to run the Hobo application at-ease. But once I do a service webroar restart the error starts appearing.

    The app runs perfectly fine on mongrel as well.

    Here are the details

    1. Rails Plugins: There are no plugins beyond the standard Hobo and its dependencies.
    2. Operating System/Kernel: Ubuntu 9.04 Server
      Linux host 2.6.18.8-xen #1 SMP Fri Oct 16 21:58:15 EDT 2009 x86_64 GNU/Linux
    3. Ruby Version:
      ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]

    May 5th, 2010 @ 03:06 PM

  5. Dharmarth Shah
    Dharmarth Shah

    Sorry, my bad, service webroar restart reproduced issue for me.

    From the man pages of service command,

    service runs a System V init script in as predictable environment as possible, removing most environment variables and with current working directory set to /.

    ...

    ...

    LANG and TERM are the only environment variables passed to the init scripts.

    The application loading is getting failed because, Rails generator is looking into home directory to locate the generators, and for that it is using HOME environment variable.

    Any specific reason behind restarting server using service command?

    You could use webroar restart or /etc/init.d/webroar restart to restart the server preserving the environment variables. Please let us know how it goes for you.

    May 6th, 2010 @ 10:22 PM

  6. GeekTantra
    GeekTantra

    Thanks a lot... Seems that was the problem. Its resolved now.

    May 6th, 2010 @ 10:54 PM

  7. Dharmarth Shah
    Dharmarth Shah
    • State changed from open to resolved

    May 7th, 2010 @ 11:55 AM

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.