Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

Activity (RSS)

Saturday, August 04 2012
25 Websocket support for Webroar was updated
Thursday, June 14 2012
25 Websocket support for Webroar was created
  • Dr. Frank J. Mabry, Jr.
    Dr. Frank J. Mabry, Jr. created the ticket at 7:18 AM

    I posted this at the Google group for "WebROaR - Ruby Application Server" but I want to be sure it also is seen by those who read this site:

    Has anyone consider...

Monday, April 11 2011
Hokam Singh Chauhan Hokam Singh Chauhan was invited to WebROaR - Ruby Application Server at 11:13 AM
Thursday, March 31 2011
22 Webroar does not provide better handling for the exceptions. was updated
  • Nikunj Limbaseeya
    • Tag set to analyzer, exception
    • State changed from open to resolved
    by Nikunj Limbaseeya at 12:41 PM

    Fixed duplicate exception creation issue by improving exception fetching query in MessageAnalyzer#process_exceptions.

    For more derail please refer https://githu...

  • Nikunj Limbaseeya
    • State changed from new to open
    by Nikunj Limbaseeya at 12:40 PM
23 Webroar loading the old data when adding a new application with the same name... was updated
  • Nikunj Limbaseeya
    • Tag set to analyzer
    • State changed from new to resolved
    • Assigned user set to Nikunj Limbaseeya
    by Nikunj Limbaseeya at 12:31 PM

    Solved the issue by enhancing the code to create/delete application record at the time of
    deploying/undeploying the application. Previously it was created from ...

Tuesday, February 22 2011
24 Webroar does not load static assets of rails 3 application in production mode was updated
  • Nikunj Limbaseeya
    • State changed from new to invalid
    by Nikunj Limbaseeya at 1:06 PM

    The issue is faced when running Rails 3 application using prefix. It is application specific issue, WebROaR is not responsible for the same.

Friday, February 18 2011
24 Webroar does not load static assets of rails 3 application in production mode was created
  • Hokam Singh Chauhan
    Hokam Singh Chauhan created the ticket at 11:32 AM

         I am having an issue regarding deployment of my rails 3 application in production mode. In Webroar when i am deploying my rails 3 application with developm...

Friday, February 11 2011
22 Webroar does not provide better handling for the exceptions. was updated
  • Hokam Singh Chauhan
    Hokam Singh Chauhan commented at 11:47 AM

    Hi,
    example :- how webroar is counting the same exception as different because of different object id in exception.

    Exception Class URL Occurrences Time
    und...
Thursday, February 10 2011
23 Webroar loading the old data when adding a new application with the same name... was created
  • Hokam Singh Chauhan
    Hokam Singh Chauhan created the ticket at 7:02 PM

    Hi,
    In webroar when i am adding an application with the same name that i have been deleted, but with different entries in all other fields, that time webroar is...

22 Webroar does not provide better handling for the exceptions. was created
  • Hokam Singh Chauhan
    Hokam Singh Chauhan created the ticket at 6:23 PM

    Hi,
    Webroar does not provide the proper handling of incoming exceptions. In webroar when an exception arrives, webroar checks the exception with exception_messa...

Wednesday, June 23 2010
8 don't require sudo was updated
  • Dharmarth Shah
    • Tag set to sudo
    • State changed from open to invalid
    • Assigned user changed from Aditya Babbar to Dharmarth Shah
    by Dharmarth Shah at 6:23 PM

    During installation server creates softlink to few executables, service script and log rotate script. All these operations requires sudo privilege.

    We would loo...

12 WebROaR Gem Path was updated
20 installation of webroar gem on Ruby Enterprise edition was updated
Friday, May 21 2010
1 Server head keeps on trying repeatedly to create a new worker if it fails to ... was updated
  • Nikunj Limbaseeya
    • State changed from open to resolved
    by Nikunj Limbaseeya at 12:33 PM

    Modified application structure to wait for 30 minutes before forking new worker, if three consecutive workers got timed out.

Friday, May 07 2010
21 Webroar not able to deploy a specific app was updated
Thursday, May 06 2010
21 Webroar not able to deploy a specific app was updated
  • GeekTantra
    GeekTantra commented at 10:55 PM

    Thanks a lot... Seems that was the problem. Its resolved now.

  • Dharmarth Shah
    Dharmarth Shah commented at 10:24 PM

    Sorry, my bad, service webroar restart reproduced issue for me.

    From the man pages of service command,

    service runs a System V init script in as predictable env...

Wednesday, May 05 2010
21 Webroar not able to deploy a specific app was updated
  • GeekTantra
    GeekTantra commented at 3:08 PM

    Thanks for the reply.

    As I mentioned earlier the error doesn't appear when WebROaR is freshly installed. I am able to run the Hobo application at-ease. But once...

Tuesday, May 04 2010
21 Webroar not able to deploy a specific app was updated
  • Dharmarth Shah
    • State changed from new to open
    by Dharmarth Shah at 7:18 PM
  • Dharmarth Shah
    • Tag changed from internal server error to application loading, internal server error
    by Dharmarth Shah at 5:34 PM

    Thanks for taking time to report the issue.

    From the log, we felt it could be Hobo application creating this problem, but sample Hobo application is running per...

  • GeekTantra
    GeekTantra commented at 3:22 PM

    This doesn't happen when I create the app in a fresh install of WebROaR, But whenever I do a service webroar restart this bug appears.

  • GeekTantra
    GeekTantra created the ticket at 9:56 AM

    Hi,

    My WebROaR is able to deploy standard Rails Applications but there is a specific application which has some plugins installed which its not able to deploy. ...

Friday, April 23 2010
20 installation of webroar gem on Ruby Enterprise edition was updated
  • Dharmarth Shah
    • Tag set to installation libruby.so
    • State changed from new to open
    • Assigned user set to Dharmarth Shah
    by Dharmarth Shah at 7:37 PM

    Sunil,

    Server needs dynamic ruby library(libruby.so) as prerequisite. If you have used 'installer' script to install REE, please rebuild your REE by passing '--...

Thursday, April 22 2010
20 installation of webroar gem on Ruby Enterprise edition was created
  • sunil sagar
    sunil sagar created the ticket at 9:43 AM

    Hi Guys,

    Facing issue on installation of webroar gem on REE v1.8.7-2010.01.
    Getting error as "libruby.so" no found.

    Anyone installed webroar on REE successfully...

Monday, April 12 2010
19 Unable to deploy app on WebRoar was updated
Sunday, April 11 2010
19 Unable to deploy app on WebRoar was updated
  • GeekTantra
    GeekTantra commented at 8:30 AM

    Thanks for the reply. It solved the problem. WebRoar looks awesome.

Wednesday, April 07 2010
7 specs hang was updated
  • Dharmarth Shah
    • State changed from new to resolved
    • Tag set to test-suite
    • Assigned user set to Dharmarth Shah
    by Dharmarth Shah at 12:47 PM

    Thanks for trying out WebROaR and taking time to report the issue.

    Sorry for the delay in reply.

    Earlier we had redirected the output of test execution to prede...

Monday, April 05 2010
18 Internal Server Error when adding applications was updated
  • Nikunj Limbaseeya
    • State changed from open to resolved
    • Assigned user set to Nikunj Limbaseeya
    by Nikunj Limbaseeya at 1:01 PM

    Kieran,

    We have fixed the bug, implemented an additional mechanism to send ERROR control message, if worker was unable to load an application.

    Could you please ...

Monday, March 29 2010
19 Unable to deploy app on WebRoar was updated
  • Dharmarth Shah
    • Tag changed from internal server error, rails, ubuntu, worker to rack dependency
    • State changed from new to open
    • Assigned user changed from Nikunj Limbaseeya to Dharmarth Shah
    by Dharmarth Shah at 6:31 PM

    Thanks for trying out WebROaR and reporting the issue.

    Could you please check the rack versions installed on your system? We were able to reproduce this issue w...

Saturday, March 27 2010
19 Unable to deploy app on WebRoar was created
  • GeekTantra
    GeekTantra created the ticket at 12:57 AM

    Hi,

    I have been trying to deploy a simple testapp on Webroar but keep getting the following error in /var/log/webroar/TestApp.log

    /var/www/rails-apps/testapp/co...

Thursday, March 25 2010
18 Internal Server Error when adding applications was updated
  • Dharmarth Shah
    • State changed from new to open
    • Tag changed from internal server error, bug to internal server error
    by Dharmarth Shah at 10:29 AM

    Thanks for trying out WebROaR and reporting the issue.

    There is a bug. When some erroneous application having its minimum number of workers greater than 2 is be...

Wednesday, March 17 2010
17 Wrong detection of remote IP after receiving malformed(?) HTTP request was updated
  • perrycz
    perrycz commented at 8:00 PM

    Actualy that second request is from remote rails application (active resource). The log entries are right.

    Do you want me to send more logs? It's from productio...

Thursday, March 04 2010
17 Wrong detection of remote IP after receiving malformed(?) HTTP request was updated
  • Dharmarth Shah
    • State changed from new to open
    • Assigned user set to Dharmarth Shah
    by Dharmarth Shah at 1:13 PM

    Thank you for taking the time out to report the issue.

    We tried out sending different kind of malformed requests (missing protocol version, large request uri, l...

Saturday, February 27 2010
4 Webroar Installation fails was updated
  • Gary Doades
    Gary Doades commented at 10:22 PM

    Yes, this fixes the installation issue on Arch.

    Thanks,
    Gary.

Thursday, February 25 2010
16 Typo was updated
  • Aditya Babbar
    • Assigned user set to Aditya Babbar
    • State changed from new to resolved
    by Aditya Babbar at 11:36 PM

    Thank you for pointing it out. I really appreciate you taking time out and raising this issue.

    Fixed it on the FAQ page and the introductory blog post.

17 Wrong detection of remote IP after receiving malformed(?) HTTP request was created
  • perrycz
    perrycz created the ticket at 5:21 PM

    As you can see in the log below, first request is correct but after receiving malformed(?) request server is assigning the same remote IP to all request. – The ...

Tuesday, February 23 2010
4 Webroar Installation fails was updated
  • Nikunj Limbaseeya
    • State changed from open to resolved
    by Nikunj Limbaseeya at 8:23 PM

    Gary,
    Thank you for trying out WebROaR on Arch Linux and reporting the issue.

    WebROaR installer failed to generate the service script in /etc/init.d and threw t...

Monday, February 22 2010
16 Typo was created
  • reso
    reso created the ticket at 10:28 PM

    In the FAQ the line:

    If you want to make your deployments (more) easier, extract more performance from your application or want an integrated solution to view t...

Wednesday, February 10 2010
5 Webroar has dependency on starling-starling gem which does not exist on GemCu... was updated
  • Dharmarth Shah
    • State changed from open to resolved
    by Dharmarth Shah at 5:15 PM

    Dependency moved to Starling gem 0.10.1 available on Gemcutter.

14 Sometime Worker(s) not connecting to Starling server was updated
  • Dharmarth Shah
    • State changed from new to resolved
    by Dharmarth Shah at 3:34 PM

    It looks like starling is reading the entire queue log file before the very first operation on it. It takes a long time to respond to the first few calls and IO...

Monday, February 01 2010
13 Building webroar with MacPorts Ruby was updated
  • btm
    btm commented at 7:14 AM

    OK, this solution works for me too. All application is running, and SSL support works fine.
    Thanks!

  • donncha
    donncha commented at 4:26 AM

    OK, solution works for me. Application is up and running now. Thanks.

Friday, January 29 2010
13 Building webroar with MacPorts Ruby was updated
  • Nikunj Limbaseeya
    • State changed from open to resolved
    by Nikunj Limbaseeya at 9:51 PM

    @btm,

    Thank you for suggesting using otool. It helped exposing the exact problem to us. My apologies for not looking in to it that deeply yesterday, i just chec...

  • donncha
    donncha commented at 8:43 AM

    Exactly the same problem here:

    bash-3.2$ sudo gem uninstall actionmailer actionpack activerecord activeresource activesupport
    ... All versions

    bash-3.2$ gem sou...

Thursday, January 28 2010
13 Building webroar with MacPorts Ruby was updated
  • btm
    btm commented at 8:01 AM

    I try MacOSX 10.5(My report is 10.6) and get same error.
    Don't use my patch, otool return this result.

    $ otool -L /opt/local/lib/ruby/gems/1.8/gems/webroar-0.2...
15 multiple host names doesn't work was updated
  • perrycz
    perrycz commented at 6:41 AM

    Yes, it is now working! Thank you so much! :)

Wednesday, January 27 2010
15 multiple host names doesn't work was updated
  • Dharmarth Shah
    • State changed from open to resolved
    by Dharmarth Shah at 11:09 PM

    Thank you for trying out WebROaR and reporting this issue.

    The server was not able to work with multiple host names correctly due to strtok() related code issue...

13 Building webroar with MacPorts Ruby was updated
  • Nikunj Limbaseeya
    Nikunj Limbaseeya commented at 10:16 PM

    Thank you for trying out WebROaR.

    We tried running WebROaR with MacPorts Ruby and did not face any issues. Here are the steps followed by us on Mac OS X 10.5.7:

    ...
  • Nikunj Limbaseeya
    • State changed from new to open
    • Assigned user set to Nikunj Limbaseeya
    by Nikunj Limbaseeya at 10:02 PM