Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

Sometime Worker(s) not connecting to Starling server

#14

Sometimes Rails/Rack application worker is not able to connect to Starling sever. Worker would remain alive and continue to serve requests, but Analytics and Exception notification for that worker would not work. Following is the sample error trace seen in the /var/log/webroar/APPLICATION_NAME.log.

Mon Jan 25 18:59:42 2010-26988-Info:setting log level to SEVERE
Mon Jan 25 18:59:42 2010-26988-Info:Ruby interpreter initialized successfully
Mon Jan 25 18:59:46 2010-26988-Error:Dispatching message on queue:No active servers
Mon Jan 25 18:59:46 2010-26988-Error:/usr/local/rvm/gems/ruby-1.8.7-p72/gems/memcache-client-1.7.7/lib/memcache.rb:646:in `stats'
/usr/local/rvm/gems/ruby-1.8.7-p72/gems/starling-0.10.1/lib/starling.rb:83:in `sizeof'
/usr/local/rvm/gems/ruby-1.8.7-p72/gems/webroar-0.2.7/src/ruby_lib/profiler/message_dispatcher.rb:82:in `send_entry'
/usr/local/rvm/gems/ruby-1.8.7-p72/gems/webroar-0.2.7/src/ruby_lib/profiler/message_dispatcher.rb:56:in `send_pid'
/usr/local/rvm/gems/ruby-1.8.7-p72/gems/webroar-0.2.7/src/ruby_lib/profiler/message_dispatcher.rb:104
/usr/local/rvm/rubies/ruby-1.8.7-p72/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/usr/local/rvm/rubies/ruby-1.8.7-p72/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/usr/local/rvm/gems/ruby-1.8.7-p72/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/usr/local/rvm/gems/ruby-1.8.7-p72/gems/webroar-0.2.7/src/ruby_lib/webroar_app_loader.rb:53
Mon Jan 25 18:59:46 2010-26988-Info:Dispatching pid on queue failed.
Mon Jan 25 18:59:46 2010-26988-Info:Exception notification would not work.
Mon Jan 25 18:59:46 2010-26988-Info:Application loaded successfully
Mon Jan 25 18:59:46 2010-26988-Info:Successfully loaded rack application=/usr/local/rvm/gems/ruby-1.8.7-p72/gems/webroar-0.2.7/src/admin_panel with environment=production
Mon Jan 25 18:59:46 2010-26988-Info:Worker ready for serving requests.
Mon Jan 25 18:59:46 2010-26988-Info:Successfully connected with client. Read watcher starting
Mon Jan 25 18:59:46 2010-26988-Info:Worker connected with Head.

Reported by Dharmarth Shah · January 25th, 2010 @ 07:32 PM

State: resolved
Milestone: none
Assigned to: Dharmarth Shah Dharmarth Shah

Activity

  1. Dharmarth Shah
    Dharmarth Shah
    • State changed from new to resolved

    It looks like starling is reading the entire queue log file before the very first operation on it. It takes a long time to respond to the first few calls and IO timeout error is thrown by memcache-client. Currently it is fixed by increasing timeout value to 15 seconds when sending PID.

    February 10th, 2010 @ 03:34 PM

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.