#4 ✓resolved
Gary Doades

Webroar Installation fails

Reported by Gary Doades | November 27th, 2009 @ 06:08 PM

Platform Arch Linux
All gems install OK, but running webroar install gives the followinf sequence:

[root@gary2 gpd]# webroar install Checking for the dependencies ...
Checking for ruby........found at /usr/bin/ruby.
Checking for libruby.so.1.8.7........found.
Checking for openssl-ruby........found.
Checking for zlib-ruby........found.
Checking for ruby_headers........found at /usr/lib/ruby/1.8/i686-linux/ruby.h.
Checking for rubygems........found.
Checking for gcc........found at /usr/bin/gcc.
Checking for make........found at /usr/bin/make.
Checking for libsqlite3.so........found at /usr/lib/libsqlite3.so.
Checking for sqlite3.h........found at /usr/include/sqlite3.h.
Checking for starling........found at /usr/bin/starling.
Checking for any previous installation of WebROaR ... not found.
Setting up server admin panel ...
Please enter a username for the administrator account of server's admin panel: gpd
Please enter a password(minimum 6 characters) for the administrator account of server's admin panel:
Confirm password:
Setting up server specifications ...
Enter server port (default is 3000): 4000
Creating directory structure ... done.
Compiling C source files ... done.
Installing server ...
Setting up server admin panel application database ... done.
Generating service script .../usr/lib/ruby/gems/1.8/gems/webroar-0.2.3/lib/installer.rb:115:in readline': end of file reached (EOFError)<br/>

    from /usr/lib/ruby/gems/1.8/gems/webroar-0.2.3/lib/installer.rb:115:in `create_service'
    from /usr/lib/ruby/gems/1.8/gems/webroar-0.2.3/lib/installer.rb:228:in `install'
    from /usr/lib/ruby/gems/1.8/gems/webroar-0.2.3/lib/command_runner.rb:204:in `run'
    from /usr/lib/ruby/gems/1.8/gems/webroar-0.2.3/bin/webroar:39
    from /usr/bin/webroar:19:in `load'
    from /usr/bin/webroar:19

Comments and changes to this ticket

  • Nikunj Limbaseeya

    Nikunj Limbaseeya December 17th, 2009 @ 01:44 PM

    • State changed from “new” to “open”
    • Assigned user set to “Nikunj Limbaseeya”
  • Nikunj Limbaseeya

    Nikunj Limbaseeya February 23rd, 2010 @ 08:23 PM

    • State changed from “open” to “resolved”

    Gary,
    Thank you for trying out WebROaR on Arch Linux and reporting the issue.

    WebROaR installer failed to generate the service script in /etc/init.d and threw this error. We have checked in a fix to ensure /etc/rc.d is used as the alternate option if init.d is not present.

    Could you please try out the latest code and let us know how it goes on your system?

  • Gary Doades

    Gary Doades February 27th, 2010 @ 10:22 PM

    Yes, this fixes the installation issue on Arch.

    Thanks,
    Gary.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Source Code Location
Repository is at http://github.com/webroar/webroar


Check out the development master:
git clone git://github.com/webroar/webroar.git


Creating a bug report

When creating a bug report, be sure to include as much relevant information as possible.


Security vulnerabilities should be reported via an email to security@webroar.in, do not use lighthouse for reporting security vulnerabilities. All content in lighthouse is publicly available as soon as it is posted.

Shared Ticket Bins

People watching this ticket

Pages